Fandom

Documentation

Global Downloader

133pages on
this wiki
Add New Page
Talk0 Share

About Edit

Global Downloader (GD)

GD is a universal application to search and download files from the Internet quickly and conveniently. It combines many functions of different Internet programs like P2P client, FTP client and Download Manager. After purchasing GD you will get many Internet applications in one program free of charge. GD has a nice looking user interface and it’s very easy to use.


Registration Edit

Global Downloader is not free. During 30 days trial period you should register the product. After the expiration of the trial period GD will stop working and you should either purchase GD to continue to use it or uninstall it. After the registration you will also get the following

  • The license to use GD on one computer
  • Priority product support service
  • Free upgrade during one year after the product registration


Starting the application Edit

After starting GD you will see the main application window with a toolbar and 3 frames. “Manage Windows” and “Log Window” frames can be moved to any place of the main window. The third frame takes up the remaining free space of the main window and consists of MDI (multi document interface) windows, which you can open with “Transfers”, “Navigator”, “Site Manager” and “Find Result” tabs.


“Manage Windows” Edit

To move “Manage Window” frame to another place within the main window, you should point the mouse pointer on the name of the frame, press and hold down (keep pressed) the left mouse button while moving the frame to a desired position.

If you want the frame to be a floating window, double click it with left mouse button on the name of the frame.


“Ехplorer” Tab Edit

On “Ехplorer” tab GD displays files and folders from a local computer or from FTP servers.

To go to a local or remote address, you may enter the address in a text field on “Manage Windows -> Explorer” tab toolbar and press See the picture above.

To refresh content on “Manage Windows -> Explorer” tab, you may press on reload button or right click on a window content field and pick “Refresh” command from the context menu. See the picture below.


“Find” Tab Edit

To find files in the Internet you should make a search query. On “Find” tab GD has a text field and a set of filters to make a search query. The query is performed using all installed protocol plug-ins. In beta version only P2P protocol is available. P2P network protocol let you find files in the Internet quickly and download them conveniently. To submit a query, enter the query in the text field, set necessary filters, and click on Find button.


MDI Windows Edit

For switching between MDI windows you may use tabs if windows are maximized, or you may use the menu items in “Window” menu.


“Navigator” tab Edit

The “Navigator” tab has all the same elements and the same functionality as “Explorer” tab. If you open “Explorer” and “Navigator” windows at the same time, it’s possible copy or move files from one window to another. It’s possible to use drag and drop, or copy and paste commands to copy files.

Global Downloader can copy files from FTP server to a local computer or from FTP server to FTP server or from the local computer to FTP server or from one folder on the local computer to another folder on the local computer. Global Downloader can also copy files from P2P networks to the local computer.

It’s possible to copy files by dragging them from “Navigator” to “Explorer” window or vice versa. It’s also possible to use “Copy” and “Paste” commands

By using right click context menu you may create new folders or delete existing folders or files on the local computer or FTP servers.


“Transfers” tab Edit

“Transfers” tab shows files being downloaded along with the information about files and download process.

You can pause, start or delete a transfer by picking the correspondent menu item from right click context menu.


“Site Manager” tab Edit

Site Manager” tab displays a tree view of FTP servers by categories. You can edit, add, or delete the information in the tree view. To add a new folder or a new site, select a required subgroup and click the right mouse button. In context menu pick “New Folder” or “Add new site”

You can edit additional information about a selected server in the right pane of the site manager.


“Find Result” tab Edit

“Find Result” window is split into 2 panes. Left pane is the query pane and it displays search queries in the order they were submitted. Right pane is the results pane and it shows search results correspondent to the selected query in the left pane.

“Find Result” tab contents is filled automatically when you enter new queries in “Find” tab or when GD retrieves search results for a submitted query.

If the number of search results is too large then you can browse through the results using a page index control that is located below the search results window. See the picture below.

To download a file found by GD or to download a group of files, you can select the files and click the right mouse button. In context menu pick “Copy” menu item, then select a place in “Explorer” or “Navigator” window where to download the files. Click the right mouse button on the destination place in “Explorer” or “Navigator” window, and pick “Paste” menu item from the context menu.

If you double click on a file name in search results window or pick “Download” item in context menu, then GD will ask about the path where to save the file and then begin downloading the file.

To connect to a selected server, choose “Connect” menu item in the right click context menu. See the picture below.


Log Window Edit

“Log Window” as well as “Manage Windows” frame can be moved to any location within the main GD window. “Log Window” shows information about the communication between GD and FTP servers.


Download files Edit

Global Downloader can download files from FTP servers to other FTP servers and to a local computer. It can also upload files from a local computer to FTP servers.

You should do the following to start downloading from an FTP server to a local computer:

1. Connect to an FTP server in “Explorer” or “Navigator” window

2. Choose the place where to save the file in “Navigator” or “Explorer” window

3. You can start downloading using either “Download” command from right click context menu, or using “Copy” and “Paste” commands, or by dragging the file and dropping it to “Navigator” or “Explorer” window.

4. Go to “Transfers” window and verify that the download has been started.

To start downloading from a P2P network to a local computer, you will need to do the following:

1. Find the files that you want in P2P network.

2. Select the files that you need to download in the right pane of “Find Result” window

3. Start downloading by using “Download” command, or “Copy” and “Paste” context menu commands, or by using Drag and Drop.

4. Go to “Transfers” window and verify that the download has been started.

To start downloading from an FTP server to an FTP server, you will need to do the following:

1. Connect to one server in one “Explorer” or “Navigator” window.

2. Connect to another server in another “Navigator” or “Explorer” window.

3. Start downloading by using “Download”, or “Copy” and “Paste” context menu commands, or by using Drag and Drop.

4. Go to “Transfers” window and verify that the download has been started.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.